Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 API not working from my phone?

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
kokeshi
Lapin nain
Lapin nain
avatar

Localisation : Bristol, UK
Nabaztag : kokeshi
Nbr de messages : 2
Carottes : 4125

MessageSujet: API not working from my phone?   Ven 7 Avr 2006 - 14:56

Hi all, wondered if I could pick your collective brains about something.

I wrote a little Python script for my phone (Nokia 6680) to change my rabbit's ear position using an API call like http://www.nabaztag.com/vl/FR/api.jsp?sn=XXXXXXXXXXXX&token=XXXXXXXXXX&idapp=XXXXXXXX&posleft=8&posright=8 and all was well, worked fine. Tried it again this morning and nothing doing, phone couldn't connect to the Nabaztag server. I registered for an appliction ID and tried again, with the URL seen above, and it worked once but then - no more!

My phone's net connection is fine, and the URL works when I try it in a browser. I was wondering if there was anyone who could tell me whether the API was ignoring phone-like requests, or if it would be better to identify myself as a particular user agent, or if the server was erratic at the moment? Anyone have any ideas? All suggestions/advice very gratefully received.

Thank you very much!
Revenir en haut Aller en bas
marfab
Cuniculussologue
Cuniculussologue
avatar

Age : 46
Localisation : Noisy le Grand
Nabaztag : Petitbrou, Landry (V1), Scrubs (V2)
Nbr de messages : 8128
Carottes : 4481

MessageSujet: Re: API not working from my phone?   Ven 7 Avr 2006 - 15:45

Hi,

I dont' think that API knows if it's a phone or a web browser like IE. At this link http://marfab.club.fr/nabaztag/wap.zip you will have a WAP site in order to change ears positions and send messages to your Rabbit.

It may help you.

See you
Revenir en haut Aller en bas
http://www.internetmobile20.com
kokeshi
Lapin nain
Lapin nain
avatar

Localisation : Bristol, UK
Nabaztag : kokeshi
Nbr de messages : 2
Carottes : 4125

MessageSujet: Re: API not working from my phone?   Ven 7 Avr 2006 - 16:31

That's a great link - thank you! I was trying to use an internet connection, rather than WAP, as I'm not on the French mobile networks . Ideally I'd be using SMS but not an option at the moment I guess.

I think I solved my problem, by the way - was trying to write to an empty file, I think, so clearing it away seems to have solved things.

Thank you for your help! wasn't expecting a response for ages.

cheers,
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: API not working from my phone?   

Revenir en haut Aller en bas
 
API not working from my phone?
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Hi-tech] Le téléphone portable un phénomène au Japon.
» Vista Gadget not working
» forfait téléphone avec textos illimités
» Text To Speech Not Working
» Téléphone Support Nabaztag

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: IV. I Don't Speak French! :: Archives :: API & Developments-
Sauter vers: