Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 Problème OJN : compte utilisateur ?

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
maxephiroth
Lapin nain
Lapin nain


Localisation : Troyes
Nbr de messages : 7
Carottes : 2267

MessageSujet: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 1:37

Bonsoir,

j'ai installé hier OpenJabNab pour lapin, parce que de le voir si pâle me chagrine.

Je précise que je fais tourner ça sous Debian Squeeze, arch ARM.

Apache2 est installé, PHP aussi, le mod-rewrite est active.
J'ai cloné le GIT, fait un qmake -r && make, tout semble bon.

Voici mes fichiers de config : /etc/apache2/sites-enabled/nabz
Code:
<VirtualHost *:80>
        ServerAdmin adresse@domaine

        DocumentRoot /var/www/OpenJabNab/http-wrapper

        <Directory /var/www/OpenJabNab/http-wrapper>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

Vient ensuite /var/www/OpenJabNab/server/bin/openjabnab.ini
Code:
[Config]
httpListener = true
httpApi = true
httpVioletApi = true
xmppListener = true
RealHttpRoot = /var/www/OpenJabNab/http-wrapper/ojn_local/
HttpRoot = ojn_local
HttpPluginsFolder = plugins
StandAloneWelcome = false
StandAloneAuthBypass = false
StandAloneAuthBypassBunny =
Bootcode = bootc
StandAloneUseLocalBootcode = true
AllowAnonymousRegistration=true
AllowUserManageBunny=true
AllowUserManageZtamp=true
SessionTimeout=300
TTS=acapela
MaxNumberOfBunnies=64
MaxBurstNumberOfBunnies=72
httpViolet = true
SaveBootcode=false
ProxyUseLocalBootcode=false


[OpenJabNabServers]
PingServer=domaine
BroadServer=domaine
XmppServer=domaine
ListeningHttpPort=8080

[Log]
LogFile=openjabnab.log
LogFileLevel=Debug
LogScreenLevel=Warning

Et pour terminer : server/bin/plugins/plugin_auth.ini
Code:
[global]
authMethod=full

Bon. Je me suis rendu via navigateur sur domaine/ojn_admin/install.php , il bidouille le remplacement dans common.php, puis me redirige sur register.php . Et si je veux créer un compte, il affiche "Error :", sans plus de précisions. Utile yellownabzhappy

Donc voilà le hic.
D'où pensez-vous que ça vienne ? Un problème dans le VHost d'Apache ?

Je précise que le répertoire OpenJabNab et son contenu appartiennent à www-data (utilisateur Apache, lui-même lancé au boot), j'ai mis un chmod récursif en 777 mais rien n'y fait... et je lance le server en tant que root.

Avez-vous des idées ? Merci d'avance !

Maxime
Revenir en haut Aller en bas
Alexjd
Bronze Nabz
Bronze Nabz
avatar

Localisation : PACA
Nabaztag : Lapinou
Nbr de messages : 181
Carottes : 2650

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 2:10

Si tu as démarré le bin d'OJN, il devrait t'en dire plus dans ses logs (openjabnab.log ou directement en console). Sinon, tu peux aussi jeter un oeil dans les logs d'Apache...
Revenir en haut Aller en bas
maxephiroth
Lapin nain
Lapin nain


Localisation : Troyes
Nbr de messages : 7
Carottes : 2267

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 8:27

Voici un lancement d'OJN :
Code:
[12/08/2011 08:13:00] -- OpenJabNab Start --
[12/08/2011 08:13:00] Finding tts in : /var/www/OpenJabNab/server/bin/tts
[12/08/2011 08:13:00] Loading libtts_acapela.so : acapela OK, Enable : Yes
[12/08/2011 08:13:00] Loading libtts_google.so : google OK, Enable : Yes
[12/08/2011 08:13:00] Finding accounts in : /var/www/OpenJabNab/server/bin/accounts
[12/08/2011 08:13:00] void AccountManager::LoadAccounts() : No account loaded ... inserting default admin
[12/08/2011 08:13:00] Total of accounts: 1
[12/08/2011 08:13:00] Finding plugins in : /var/www/OpenJabNab/server/bin/plugins
[12/08/2011 08:13:00] Loading libplugin_annuaire.so : annuaire OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_auth.so : auth OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_boot.so : boot OK, Enable : Yes
[12/08/2011 08:13:00] Cron Started...
[12/08/2011 08:13:00] Cron Register : Clock - Fri Aug 12 09:00:00 2011
[12/08/2011 08:13:00] Loading libplugin_clock.so : clock OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_colorbreathing.so : colorbreathing OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_dice.so : dice OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_ears.so : ears OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_ephemeride.so : ephemeride OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_locate.so : locate OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_msgall.so : msgall OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_music.so : music OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_packet.so : packet OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_record.so : record OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_rfid.so : rfid OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_sleep.so : sleep OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_surprise.so : surprise OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_taichi.so : taichi OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_test.so : test OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_tts.so : tts OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_tv.so : tv OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_weather.so : weather OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_webradio.so : webradio OK, Enable : Yes
[12/08/2011 08:13:00] Loading libplugin_xmppport.so : xmppport OK, Enable : Yes
[12/08/2011 08:13:00] Finding bunnies in : /var/www/OpenJabNab/server/bin/bunnies
[12/08/2011 08:13:00] Finding ztamps in : /var/www/OpenJabNab/server/bin/ztamps
[12/08/2011 08:13:00] XMPP Port is: 5222
[12/08/2011 08:13:00] Parsing of HTTP Api is enabled
[12/08/2011 08:13:47] Cron Register : Clock - Fri Aug 12 09:00:00 2011
[12/08/2011 08:13:47] -- OpenJabNab Close --

Et le log d'Apache :
Code:
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Warning:  Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Fri Aug 12 08:19:08 2011] [notice] Apache/2.2.16 (Debian) configured -- resuming normal operations
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents():  wrapper is disabled in the server configuration by allow_url_fopen=0 in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/api.class.php $
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents(domaine/ojn_api/global/stats?): failed to open stream: no suitable wrapper could be found in /var/www/OpenJabNab/http-wrapper/o$
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: connected_bunnies in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 37, referer: domaine/ojn_admin/r$
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: bunnies in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 37, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: enabled_plugins in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 38, referer: domaine/ojn_admin/reg$
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: plugins in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 38, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: ztamps in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 39, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:29 2011] [error] [client 192.168.0.254] File does not exist: /var/www/OpenJabNab/http-wrapper/favicon.ico
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents():  wrapper is disabled in the server configuration by allow_url_fopen=0 in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/api.class.php $
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents(domaine/ojn_api/accounts/registerNewAccount?login=maxauvy&username=maxauvy&pass=cxziwa): failed to open stream: no suitable wra$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: error in /var/www/OpenJabNab/http-wrapper/ojn_admin/register.php on line 10, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents():  wrapper is disabled in the server configuration by allow_url_fopen=0 in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/api.class.php $
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents(domaine/ojn_api/global/stats?): failed to open stream: no suitable wrapper could be found in /var/www/OpenJabNab/http-wrapper/o$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: connected_bunnies in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 37, referer: domaine/ojn_admin/r$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: bunnies in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 37, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: enabled_plugins in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 38, referer: domaine/ojn_admin/reg$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: plugins in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 38, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: ztamps in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 39, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents():  wrapper is disabled in the server configuration by allow_url_fopen=0 in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/api.class.php $
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Warning:  file_get_contents(domaine/ojn_api/global/stats?): failed to open stream: no suitable wrapper could be found in /var/www/OpenJabNab/http-wrapper/o$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: connected_bunnies in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 37, referer: domaine/ojn_admin/r$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: bunnies in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 37, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: enabled_plugins in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 38, referer: domaine/ojn_admin/reg$
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: plugins in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 38, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:40 2011] [error] [client 192.168.0.254] PHP Notice:  Undefined index: ztamps in /var/www/OpenJabNab/http-wrapper/ojn_admin/class/template.class.php on line 39, referer: domaine/ojn_admin/register.php
[Fri Aug 12 08:19:41 2011] [error] [client 192.168.0.254] File does not exist: /var/www/OpenJabNab/http-wrapper/favicon.ico

C'est grave docteur ? ^^
Je regarderai cette histoire de safe_mode, il me semblait l'avoir désactivé pourtant...
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 10:25

Sinon, essaie déjà en mettant ton adresse ip de serveur dans OpenJabNab.ini... au lieu de laisser domain.

Code:
[OpenJabNabServers]
PingServer=domaine
BroadServer=domaine
XmppServer=domaine
ListeningHttpPort=8080

par

Code:
[OpenJabNabServers]
PingServer=192.168.0.254 (à confirmer, j'ai mis d'après ton log Apache)
BroadServer=192.168.0.254
XmppServer=192.168.0.254
ListeningHttpPort=8080

Ca devrait aider et te donner accès à l'admin (et affichage des stats en bas de page).
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz
avatar

Localisation : France
Nbr de messages : 1203
Carottes : 4006

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 11:19

Les .htaccess sont autorisés (AllowOverride All) ?

Quand ojn est lancé, si tu vas à l'adresse http://TON_SERVER/ojn_api/global/stats t'as des chiffres qui s'affichent ou un 404.

(Lisez les topics ^^)
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
maxephiroth
Lapin nain
Lapin nain


Localisation : Troyes
Nbr de messages : 7
Carottes : 2267

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 14:22

Alors, dans l'ordre :
1) J'avais remplacé par l'IP interne (le lapin et le serveur sont derrière la freebox, le serveur a pour IP 192.168.0.25, 192.168.0.254 correspond à la passerelle de la freebox. Est-ce que je dois essayer avec l'IP externe de la box ? Genre 87.xxx... (je précise bien sûr que les ports 80, 8080 et 5222 sont ouverts et redirigés sur le serveur... c'est évident mais tout le monde n'y pense pas. Plus le port 22, parce que SSH et SCP powaaa !)

2) Oui, mon VHost Apache est dans le premier post, on a bien AllowOverride All pour la racine du serveur

3) Si je vais sur la page stats : elle affiche 1102323. Pas d'erreur 404 de ce côté là yellownabzsmile

Et j'en ai lu, des topics, mais certains font 45 pages...
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 14:33

Essaie déjà avec 192.168.0.25 pour les trois lignes de [OpenJabNabServers].

Là, tu devrais avoir les stats de ton serveur.

Par la suite, il faudra surement prendre l'adresse externe de ta freebox, une fois que tu voudras mettre le lapin dessus, mais uniquement si ça ne fonctionne pas avec l'adresse interne (car si ça fonctionne, ça m'intéresse ^^)
Revenir en haut Aller en bas
maxephiroth
Lapin nain
Lapin nain


Localisation : Troyes
Nbr de messages : 7
Carottes : 2267

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 14:39

Re-salut,

j'ai cherché, vu les logs Apache, dans /etc/php5/apache2/php.ini

J'ai passé allow_url_fopen à On... Et j'ai pu créer un compte et ajouter mon lapin.

Je vous dis ce soir si ça fonctionne correctement.
Je testerai en interne, je te tiens au courant yellownabzsmile
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 15:25

Toujours bon à savoir pour allow_url_fopen...

Mais elle n'est pas à on par défaut ? Tu avais eu besoin de la passer à off par le passé ?
Revenir en haut Aller en bas
maxephiroth
Lapin nain
Lapin nain


Localisation : Troyes
Nbr de messages : 7
Carottes : 2267

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 19:43

Je l'avais passée à Off, effectivement, je bosse beaucoup sur la sécurité des serveurs (école d'ingé) et c'était surtout à des fins de tests, bien que la laisser sur On quand on ne s'en sert pas soit plutôt déconseillé.

Si j'avais tilté avant (beaucoup de boulot et de fatigue), ça aurait été plus vite...

Je rentre chez moi dimanche, je te dirai à ce moment là si le simple fait de changer les IP fonctionne. Il faut que je la change dans le Nabaztag, mais aussi dans common.php etc non ?

J'ai configuré le plug-in de Tai-Chi, je verrai demain soir ce que ça donne... Merci à vous en tout cas yellownabzsmile

Sinon, si quelqu'un a besoin d'un coup de main pour mettre à jour le wiki avec ce qui a été dit dans certains topics (dont mon problème), ajouter la liste des paquets à installer (dans mon cas sous Squeeze) pour que QT4 et OJN fonctionnent... Je suis partant !

Bonne soirée !
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 12 Aoû 2011 - 22:09

Pour les adresses, je n'ai pas réussi à faire fonctionner le lapin avec une adresse en 192.168...
(bon, ok, j'ai vite arrêté de chercher vu que ça passait tout seul en ip externe). C'est pour ça que si quelqu'un trouve, ça m'intéresse nabzhello2

Donc si ça ne fonctionne pas, voici comment faire :

Sur le lapin, configurer avec l'adresse externe (avec le http:// devant, et le /vl à la fin).
Sur le routeur, tu as déjà redirigé les ports, donc rien à faire.
Sur la config du common.php, il faut juste la passer à 192... si tu l'avais mise en 127.0.0.1 au début, et ça devrait suffire, vu que c'est ton routeur qui redirige tout vers ton poste en ip locale (et en pratique, même si ça fonctionne, passer par l'adresse externe ralentit l'admin... c'est beaucoup plus fluide en interne).
Sur openjabnab.ini, comme ça re-route, pas la peine de changer non plus, tu peux laisser 192.168.0.25

Voilà, Bon WE
Revenir en haut Aller en bas
maxephiroth
Lapin nain
Lapin nain


Localisation : Troyes
Nbr de messages : 7
Carottes : 2267

MessageSujet: Re: Problème OJN : compte utilisateur ?   Sam 3 Sep 2011 - 0:20

Re-salut tout le monde,

désolé pour le méga-délai, mais avec le boulot, le temps passé à regarder l'état du code d'OpenNab pour voir ce qui est faisable, toussa toussa...

Alors :
- le Tau-Chi fonctionne très bien
- le lapin me donne l'heure (j'ai fait un de ces bonds hier soir, j'avais perdu l'habitude yellownabzsmile )
- par contre : j'ai tenté de modifier la couleur de sa respiration, pour passer de violet à je sais plus quoi. Ca ne fonctionne pas...
- le ztamp RFID est bien reconnu !

Autre question : pourquoi est-ce que les oreilles reprennent toujours la même position, genre après son tai-chi ?

Si vous voulez, j'ai fait un petit tuto sur l'installation d'OpenJabNab sur ma config, je peux donner le lien si quelqu'un est intéressé... Je n'ai pas encore fait la partie installation d'Apache+PHP par contre !

Enfin, pour ce qui est de l'IP interne : ça fonctionne. Il y avait juste une petite subtilité (de mémoire, même pas sûr, je revérifierai) avec la freebox : le serveur DNS est sur 192.168.1.1 (qui a tendance à ressortir sur les DNS de Free de façon transparente, d'ailleurs), mais la passerelle est en 192.168.0.254 (freebox v5). Mais c'est possible, en tout cas. Ca a marché au moins 10min, avant que je remette tout en mode "distant" pour que ma copine puisse ajouter son tag ;-)
Revenir en haut Aller en bas
maf
Lapin nain
Lapin nain
avatar

Age : 42
Localisation : Entre Chartreuse et Belledonne
Nabaztag : Becquerel
Nbr de messages : 14
Carottes : 2801

MessageSujet: Re: Problème OJN : compte utilisateur ?   Mer 14 Sep 2011 - 22:06

Bonsoir,

J'ai le même soucis, mais manifestement les paramètres pour dans PHP.ini sont OK pour "allow_url_fopen".

Quel doit être le statut pour "allow_url_include " ?, chez moi il est à off.

Je suis sous ubuntu server 10.04.

Merci pour votre aide.

Au passage, bravo à jet pour son tuto pour OJn sur windows, cela m'a bien servi pour les essais.
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Jeu 15 Sep 2011 - 16:08

Bonjour,

maf a écrit:
Quel doit être le statut pour "allow_url_include " ?, chez moi il est à off.

Il est aussi à Off chez moi.

maf a écrit:
Au passage, bravo à jet pour son tuto pour OJn sur windows, cela m'a bien servi pour les essais.

Merci

maxephiroth a écrit:
Enfin, pour ce qui est de l'IP interne : ça fonctionne. Il y avait juste une petite subtilité (de mémoire, même pas sûr, je revérifierai) avec la freebox : le serveur DNS est sur 192.168.1.1 (qui a tendance à ressortir sur les DNS de Free de façon transparente, d'ailleurs), mais la passerelle est en 192.168.0.254 (freebox v5). Mais c'est possible, en tout cas.

Ca m'intéresse, mais je n'y arrive toujours pas chez moi (avec une v6), même en modifiant le serveur DNS (mais je n'ai rien à cette adresse, peut-être que ça a changé entre v5 et v6, je ne me souviens plus). As tu paramétré quelque chose d'autre côté DNS ? Genre un serveur DNS à toi à cette adresse ?

Tout ce que j'ai pu faire jusqu'à présent : mettre l'IP interne dans le fichier ojn.ini, ce qui fait qu'une fois le locate effectué (sur ip externe redirigée), je peux couper la redirection depuis mon IP externe (vu qu'il utilise alors les données 192.168.x.x renseignées dans l'ini). Mais cette fichue première connexion, impossible.

Bonne fin de journée
Revenir en haut Aller en bas
htristra
Silver Nabz
Silver Nabz


Age : 42
Localisation : Val d'oise France
Nabaztag : lapou et laptaf
Nbr de messages : 364
Carottes : 2701

MessageSujet: Re: Problème OJN : compte utilisateur ?   Jeu 15 Sep 2011 - 17:08

Salut,
je ne sais pas trop si c'est en rapport mais il y a un vieux truc pour la connexion du lapin via la freebox revolution.

Il faut que tu connectes à la freebox puis WIFI->Réseau personnel->Param avancés. Tu passes "Version du protocole EAPOL" à "version 1", tu redémarres et hop.

A+
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Jeu 15 Sep 2011 - 17:10

Ouii, la manip indispensable pour le que lapin puisse voir le wifi yellownabzwink

Il m'a fait peur le bougre la première fois ^^
Revenir en haut Aller en bas
PITP2
Lapin nain
Lapin nain


Localisation : belgique
Nbr de messages : 26
Carottes : 2759

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 30 Sep 2011 - 15:46

Bonjour,
j'ai suis le tuto de jet qui est super bien fait d'ailleur mais j'ai un soucis.
je suis sur windows
Je n'arrive pas créer de compte , j'ai un message d'erreur en rouge "error" et rien ne se passe en admin
j'ai lu bcp de posts et j'ai modifié les paramètres urlrewrite à true allowoverride à all
j'ai essayé d'accéder aux stats via l'url => http://xxxxxxx:8888/ojn_api/global/stats
mais j'ai ca en retour
HTTP Error 400. The request verb is invalid.

Avez vous une idée du problème ?
Revenir en haut Aller en bas
PITP2
Lapin nain
Lapin nain


Localisation : belgique
Nbr de messages : 26
Carottes : 2759

MessageSujet: Re: Problème OJN : compte utilisateur ?   Sam 1 Oct 2011 - 9:40

Je viens de refaire toute l'installation mais j'ai tjrs le même problème ...
Help nabzsteam
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Sam 1 Oct 2011 - 18:13

Bonjour,

Ca fait quelques jours / semaines que je n'ai pas touché au serveur.
Les nouvelles sources écoutent le port 8888 ?
Il faut changer les paramètres dans ce sens alors.

Je vais m'y remettre courant de semaine prochaine, en retrouvant mon ordi.
Je re-ferai l'installation complète en suivant le tuto, pour pouvoir le modifier en cas de besoin si des modifs des sources le rendent obsolète.

Revenir en haut Aller en bas
PITP2
Lapin nain
Lapin nain


Localisation : belgique
Nbr de messages : 26
Carottes : 2759

MessageSujet: Re: Problème OJN : compte utilisateur ?   Sam 1 Oct 2011 - 18:17

Citation :
Les nouvelles sources écoutent le port 8888 ?
Oui mais je ne pense pas que mon problème vienne de là car j'accède bien à la page de création du nouvel utilisateur mais après la validation j'ai le messag "error" de même le compte admin ne fonctionne pas ... nabzcry
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2450

MessageSujet: Re: Problème OJN : compte utilisateur ?   Sam 1 Oct 2011 - 19:42

Une fois ajouté le premier utilisateur, le compte admin ne fonctionne plus.
C'est juste un compte temporaire.
Le premier utilisateur créé sera le nouvel admin.

Ca n'explique pas tout, mais c'est déjà un p'tit élément.
Revenir en haut Aller en bas
Speacraft
Lapin nain
Lapin nain


Localisation : Versailles
Nbr de messages : 16
Carottes : 841

MessageSujet: Re: Problème OJN : compte utilisateur ?   Ven 4 Sep 2015 - 18:03

Désolé de resortir ce topic mais j'ai le même problème : Impossible de créer de compte utilisateur yellownabzsad Il me marque "Error:" mais c'est tout, j'ai réinstaller OJN, vérifier la config mais rien a faire.
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: Problème OJN : compte utilisateur ?   

Revenir en haut Aller en bas
 
Problème OJN : compte utilisateur ?
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Problème OJN : compte utilisateur ?
» Problème d'installation sous XP pro
» Problème de plantage du jeu
» Installation du logiciel sous Vista
» Problème de compte MSN

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: Les Nabaztags sont sauvés ! Les solutions... :: [OJN] OpenJabNab-
Sauter vers: