Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 erreur au lancement depuis un git pull ce matin

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
mine
Bronze Nabz
Bronze Nabz


Localisation : Picardie
Nbr de messages : 190
Carottes : 2283

MessageSujet: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 10:01

Bonjour,

j'ai mis à jour ce matin le serveur à l'aide d'un git pull, mais j'ai cette erreur au lancement

Code:
./openjabnab: symbol lookup error: /OpenJabNab/server/bin/plugins/libplugin_boot.so: undefined symbol: _ZN5Bunny7BootingEv

et donc bien sur le serveur s'arrete...

help ?
Revenir en haut Aller en bas
http://lapinlibre.net
mine
Bronze Nabz
Bronze Nabz


Localisation : Picardie
Nbr de messages : 190
Carottes : 2283

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:03

au pire existe t'il une fonction pour revenir sur l'ancienne version à l'aide de git ?
Revenir en haut Aller en bas
http://lapinlibre.net
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1186
Carottes : 3757

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:35

le plugin boot a disparu. Supprime le fichier libplugin_boot.so yellownabzwink
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2220

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:43

Je n'ai pas eu ton erreur avec la version a629ec94c848a3c45e16, par contre impossible de le faire booter avec le bootcode.default (il ne doit pas aller chercher le bootcode.ojn indiqué dedans).

Du coup, j'ai remplacer dans le .htaccess

Code:
RewriteRule   ^vl/bc.jsp$   /ojn_local/bootcode/bootcode.default   [L]

par

Code:
RewriteRule   ^vl/bc.jsp$   /ojn_local/bootcode/bootcode.ojn   [L]

Et là, ça boot ^^
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1186
Carottes : 3757

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:45

Si tu dois remplacer dans le .htaccess c'est que t'es pas à jour correctement yellownabzwink
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2220

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:50

C'est pas la dernière la a629ec94c848a3c45e16 ?
Revenir en haut Aller en bas
mine
Bronze Nabz
Bronze Nabz


Localisation : Picardie
Nbr de messages : 190
Carottes : 2283

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:51

Merci comme d'hab tu es d'une aide précieuse...
par contre plus d'erreur au lancement, mais les lapins n'arrivent plus à se connecter, il y a t'il d'autres changements à faire ?
Revenir en haut Aller en bas
http://lapinlibre.net
mine
Bronze Nabz
Bronze Nabz


Localisation : Picardie
Nbr de messages : 190
Carottes : 2283

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 12:58

mine a écrit:
Merci comme d'hab tu es d'une aide précieuse...
par contre plus d'erreur au lancement, mais les lapins n'arrivent plus à se connecter, il y a t'il d'autres changements à faire ?

je me réponds, mon fichier .htaccess n'étais pas à jour...

Merci encore à RedoX
Revenir en haut Aller en bas
http://lapinlibre.net
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1186
Carottes : 3757

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 13:42

jet a écrit:
C'est pas la dernière la a629ec94c848a3c45e16 ?

Si. Mais j'viens de mettre mon serveur à jour, et j'ai pas eu ton soucis. C'est donc que ta mise à jour n'est pas faite correctement ^^

My bad ! Le problème vient pas du .htaccess ni de ta précédure de MaJ, mais sous Windows, le symlink n'est pas fait correctement. Faut changer le bootcode.ojn en bootcode.default
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2220

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 15:39

OK, c'était donc bien ça...

Citation :
(il ne doit pas aller chercher le bootcode.ojn indiqué dedans).

Car à chaque mise à jour, je n'utilise pas git, je reprend tout le dossier server et je recompile tout (et je me refais un serveur web admin, mais ça c'est facile), histoire de vérifier pour mon tuto que ça fonctionne bien et voir les différents messages d'erreur qu'il pourrait y avoir, pour indiquer comment les contourner.

Pour l'instant, je laisse tel quel, ça m'a permis de vérifier que le htaccess fonctionne bien ^^
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1186
Carottes : 3757

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Lun 15 Aoû 2011 - 15:49

Ouais mais sous linux les symlinks fonctionnent, on a pas de problème yellownabzhappy
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
mine
Bronze Nabz
Bronze Nabz


Localisation : Picardie
Nbr de messages : 190
Carottes : 2283

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Mar 16 Aoû 2011 - 10:28

Désolé de vous déranger à nouveau mais la mise à jour de ce matin ne provoque pas d'erreur au lancement mais les lapins ne se connectent plus au serveur...

Promis je ne fais plus de mise à jour yellownabzwink avant de voir si pour les autres cela se passe bien.
Revenir en haut Aller en bas
http://lapinlibre.net
mine
Bronze Nabz
Bronze Nabz


Localisation : Picardie
Nbr de messages : 190
Carottes : 2283

MessageSujet: Re: erreur au lancement depuis un git pull ce matin   Mar 16 Aoû 2011 - 10:40

fausse alerte... il fallait relancer les lapins...

Désolé pour le bruit.
Revenir en haut Aller en bas
http://lapinlibre.net
Contenu sponsorisé




MessageSujet: Re: erreur au lancement depuis un git pull ce matin   

Revenir en haut Aller en bas
 
erreur au lancement depuis un git pull ce matin
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Sauvegarde avec "erreur 16" depuis la dernière mise à jour
» [Vidéo] Télématin MEUPORG
» Envoi de SMS gratuits depuis Chez Patapwet avec Google Agenda !
» Erreur 131 : Signature string (1) in signaturefile file does
» Depuis le temps que je patiente dans cette chambre noire ...

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: Les Nabaztags sont sauvés ! Les solutions... :: [OJN] OpenJabNab-
Sauter vers: