Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 OpenJabNab installation not registering my rabbit (sorry english)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
ilTofa
Lapin nain
Lapin nain


Localisation : Rome, Italie
Nbr de messages : 21
Carottes : 1980

MessageSujet: OpenJabNab installation not registering my rabbit (sorry english)   Dim 18 Sep 2011 - 20:22

Mais vous pouvez répondre en français... yellownabzsmile

I just installed OpenJabNab on lighttpd on a Debian Lenny VM (it's more a joke than other, I'm an happy user os psnet.fr).

The systems apparently works, ojn_admin works admin/admin connects, I can resister my bunny (and I have a file in bunnies/

When my rap pit tries to connect I got:
void HttpHandler::HandleBunnyHTTPRequest() : Unable to handle HTTP Request :
  • URL : /vl/bc.jsp
  • Get Args :
    • h => 4
    • l => 00:00:00:00:00:00
    • m => 00:13:d3:81:06:76
    • p => 00:00:00:00:00:00
    • v => 0.0.0.10


On dump.log I have:
18/09/2011 20:19:26 - HTTP Request - /vl/bc.jsp?v=0.0.0.10&m=00:13:d3:81:06:76&l=00:00:00:00:00:00&p=00:00:00:00:00:00&h=4
Many rows, one for each attempt.

Nothing on lighttpd error log.

I tried both true and false in AllowAnonymousRegistration and AllowUserManageBunny

I think it is something really stupid what's missing... yellownabzsmile Any help will be appreciated...

btw: I managed to compile also bootstrap directory... what's the usage of it?

Thank you again! yellownabzsmile
Revenir en haut Aller en bas
Alexjd
Bronze Nabz
Bronze Nabz


Localisation : PACA
Nabaztag : Lapinou
Nbr de messages : 181
Carottes : 2377

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Dim 18 Sep 2011 - 22:24

Perhaps a problem with your XMPP port (5222 I guess).
Are you sure you have opened it on your guest firewall ?

EDIT: Je lis trop vite et m'emballe; peut-être aurais-je mieux fait de répondre en français... Dis-moi si mon anglais est trop indigeste pour un estomac italien.
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz


Age : 37
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 10474

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Dim 18 Sep 2011 - 23:04

I'm not a lighttd user, so it's difficult for me to answer.
But when using apache, there is a rewrite rule (in http-wrapper/.htaccess) to redirect every call to vl/bc.jsp to the bootcode.

Maybe you could try o search in that direction.

And about XMPP port (5222), it's not used until the bytecode is downloaded yellownabzwink (and the bytecode is downloaded with bc.jsp)

_____________________________


Toutes les infos sur mon serveur openJabNab sont sur mon wiki nabaztag/tag et openJabnab
Revenir en haut Aller en bas
http://openjabnab.fr/
ilTofa
Lapin nain
Lapin nain


Localisation : Rome, Italie
Nbr de messages : 21
Carottes : 1980

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Dim 18 Sep 2011 - 23:52

@Alexjd xmpp is OK I can connect via telnet address port (and you english is better than mine, probably). yellownabzsmile

@pixel that seems the right direction... I have the rewrite rules as in README.lightly and apparently, works for /vl (because I got the call to openjabnab.php) but that seems the right direction... I'll try to investigate it. Thank you! I'll make you know, in any case...
Revenir en haut Aller en bas
ilTofa
Lapin nain
Lapin nain


Localisation : Rome, Italie
Nbr de messages : 21
Carottes : 1980

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Lun 19 Sep 2011 - 0:29

The rewrite rules says that:
Code:
"^vl/bc.jsp$" => "/ojn_local/bootcode/bootcode.default"
bootcode.default does not exists yellownabzsmile In the distro there is bootcode.ojn and boot code.violet, copying whatever on boot code.default have no effect.
I have also recompiled the boot code and transferred here but it's the same of boot code.ojn (that was, probably, expected).
The GET of the bootcode gets a "404 Not Found" answer from openjabnab process, the chain between lighttpd, the openjabnab.php and the openjabnab daemon seems to work.
The problem is related to rewrite rule for sure, it is not working as in readme...
Asking directly for the bootcode works (of course)...
Revenir en haut Aller en bas
ilTofa
Lapin nain
Lapin nain


Localisation : Rome, Italie
Nbr de messages : 21
Carottes : 1980

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Lun 19 Sep 2011 - 0:55

Solved.
the url.rewrite-once rule in README.lightly should read

Code:
url.rewrite-once += (
    "^/vl/bc.jsp.*" => "/ojn_local/bootcode/bootcode.default",
instead of
Code:
url.rewrite-once += (
    "^vl/bc.jsp$" => "/ojn_local/bootcode/bootcode.default",
the rest of the rule is OK.
The bunny is still a bit strange... yellownabzsmile the led down center is first blue, then remains red and I have in log
Code:
Requesting LOCATE for tag 0013d3810676
HTTP request made from the bunny was
Code:
GET /vl/locate.jsp?sn=0013d3810676&h=4&v=18673 HTTP/1.0" 200 64 "-" "MTL
/ojn_admin (logging as /admin) seems to lose my bunny every time I restart the server... and my bunny seems disconnected...
But this will go to tomorrow. nabzgo
Thank you for your support. nabzsmile
Revenir en haut Aller en bas
ilTofa
Lapin nain
Lapin nain


Localisation : Rome, Italie
Nbr de messages : 21
Carottes : 1980

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Mar 20 Sep 2011 - 14:54

Just to make you know that openjabnab is now working under lighttpd with the patch on the previous message. I'll push the patch on git (as soon as I understand how to do it, I normally use svn). yellownabzsmile
The remaining error (the LOCATE one) was caused by the lack of DNS (reverse DNS).
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz


Age : 37
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 10474

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Mar 20 Sep 2011 - 16:16

Congratulations yellownabzwink

_____________________________


Toutes les infos sur mon serveur openJabNab sont sur mon wiki nabaztag/tag et openJabnab
Revenir en haut Aller en bas
http://openjabnab.fr/
ilTofa
Lapin nain
Lapin nain


Localisation : Rome, Italie
Nbr de messages : 21
Carottes : 1980

MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Mar 20 Sep 2011 - 18:20

Thank you, pixel for the nice piece of software (and for the help in installing it). yellownabzsmile If you ever need an hand, just give me a shout. yellownabzwink
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: OpenJabNab installation not registering my rabbit (sorry english)   Aujourd'hui à 20:16

Revenir en haut Aller en bas
 
OpenJabNab installation not registering my rabbit (sorry english)
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» OpenJabNab installation not registering my rabbit (sorry english)
» Bunny's no connect to OpenJabNab Server
» [Tuto] installation d'OpenJabNab sur un Pogoplug
» Tutoriel d'installation d'OpenJabNab sur un serveur Ubuntu Lamp (installation pas à pas de 0)
» [Tuto] Installation d'OpenJabNab sur un Raspberry Pi

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: Les Nabaztags sont sauvés ! Les solutions... :: [OJN] OpenJabNab-
Sauter vers: