Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 Ne pas lancer OJN à la racine

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
GuiguiWuip
Lapin nain
Lapin nain


Localisation : Nantes
Nbr de messages : 16
Carottes : 2391

MessageSujet: Ne pas lancer OJN à la racine   Lun 18 Mar 2013 - 18:32

Bonjour,

J'essaie d'installer un serveur OJN sur mon RaspberryPI (bien qu'ayant peu de connaissances linux) notamment à l'aide du tuto de loloz3 et du retour trouvé ici également.
nabzjump

La solution marche. J'accède à http ://Adresse IP du serveur/ojn_admin.
EDIT : mais c'est tout, impossible de se logger admin/admin ou de créer un compte ...

Seulement, j'ai d'autres sites installés sur mon RPI et je veux conserver l'accès dessus. Et c'est là que les choses se compliquent. Je voudrais désormais accéder à http ://Adresse IP du serveur/ojn/ojn_admin (ou trouver une solution équivalente comme un changement de ports). Et que tout cela fonctionne également du côté lapin.

J'ai testé plusieurs choses comme bidouiller les virtual Host (là encore, je n'y connais pas grand chose ...) en fonction du port (80 pour ojn et 8080 pour le reste. L'idéal serait l'inverse, mais je sais pas si le lapin apprécierai.). Je n'arrive pas à faire fonctionner cette solution, voici mes virtualhosts (192.168.0.19 est l'IP du RPI) :
Code:

Listen 80
Listen 8080

NameVirtualHost 192.168.0.19:80
NameVirtualHost 192.168.0.19:8080

<VirtualHost 192.168.0.19:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/OpenJabNab/http-wrapper
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>

        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride ALL
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel debug

        CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

<VirtualHost 192.168.0.19:8080>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>

      <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride ALL
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel debug

        CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

J'ai également voulu me pencher sur le .htaccess du côté de http-wrapper mais j'ai vite laissé tombé également.

J'ai donc besoin d'un peu d'aide pour y arriver et monter des petites app perso pour mon lapin. Quelqu'un peut-il m'aider ?

Merci d'avance !
Revenir en haut Aller en bas
jet
Bronze Nabz
Bronze Nabz


Localisation : Essonne
Nbr de messages : 158
Carottes : 2334

MessageSujet: Re: Ne pas lancer OJN à la racine   Mer 27 Mar 2013 - 21:26

Bonsoir,

Le moyen le plus simple à mon avis est de passer par un nom de domaine pour la configuration d'Apache, qui servira ainsi la partie web OJN si le nom est reconnu, et ta page par défaut sur le port 80 sinon.

Réalisable en local en installant un serveur DNS (bind9) sur le RPi, en donnant ce nom de domaine au lapin comme adresse de connexion, et l'IP du raspberry comme serveur DNS du lapin.

Ca fonctionne très bien ainsi, et en configurant ensuite d'autres noms pour tes différents sites dans bind, tu pourras te passer de la galère des changements de ports.

Tu peux t'inspirer de ce tuto tout frais sorti de presse : http://nabaztag.forumactif.fr/t14623-tuto-installation-d-openjabnab-sur-un-raspberry-pi, chapitre 2 notamment.

@+
JeT
Revenir en haut Aller en bas
GuiguiWuip
Lapin nain
Lapin nain


Localisation : Nantes
Nbr de messages : 16
Carottes : 2391

MessageSujet: Re: Ne pas lancer OJN à la racine   Mer 27 Mar 2013 - 22:01

Oui, j'ai commencé à suivre ta démarche, tout ce passe bien pour le moment. N'ayant que peu de connaissances linux et apache je ne m'en sortais pas.
La solution du nom de domaine me conviens tout à fait, merci pour ce tuto yellownabzsmile
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: Ne pas lancer OJN à la racine   

Revenir en haut Aller en bas
 
Ne pas lancer OJN à la racine
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Aspirine][Doliprane][Corde] La racine carrée
» Set fleurs de Racine.
» Panda Soutien (sagesse-dommages) - Viable ?
» [Recettes] Batons
» Question build THL

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: Les Nabaztags sont sauvés ! Les solutions... :: [OJN] OpenJabNab-
Sauter vers: