Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 Problème de connection a mon serveur

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
jojolapinou
Lapin nain
Lapin nain


Age : 33
Localisation : judo63
Nabaztag : lejojolapinou
Nbr de messages : 5
Carottes : 3646

MessageSujet: Problème de connection a mon serveur   Dim 8 Fév 2015 - 19:05

Bonjour,

Après un long moment d'inactivité j'ai voulut remettre en fonction mon lapin.

Je me suis donc procuré un raspberry et j'ai suivit ce tutoriel pour l'installation http://www.journaldulapin.com/2013/04/10/un-serveur-nabaztag-maison-avec-le-raspberry-pi/

Mais j'ai rencontré un problème, et après une semaine de recherche et de test divers je fais appel a vous car le problème que j'ai rencontré et similaire à d'autres sujet sur le forum mais tout a fait pareil.
En fait mon problème est que mon lapin se connecte bien au serveur mais, quand je vais dans l'interface opennabjab il apparait comme déconnecté. Et la led du milieu reste allumée orange fixe.
Sur ma freebox j'ai redirigé le port TCP 5222 vers l'adresse IP du serveur

J'ai bien vérifié tous les paramètres ils m'ont l'air correctes, et j'ai regardé dans les log je n'ai pas de message d'erreur explicite.

Il y a quand même une chose qui me parait étrange, quand je vais dans les paramètres du lapin dans le cadre Degug features, l'heure dans Last locate est bonne mais l'adresse IP du lapin n'apparait pas.



Donc si quelqu'un a une idée ou une piste que je pourrais explorer ca m'aiderais beaucoup.

Merci


Le log de opennabjab.log

Code:

30/01/2015 17:50:01] -- OpenJabNab Start --
[30/01/2015 17:50:01] Finding tts in : /var/www/OpenJabNab/server/bin/tts
[30/01/2015 17:50:01] Loading libtts_acapela.so : acapela OK, Enable : Yes
[30/01/2015 17:50:01] Loading libtts_google.so : google OK, Enable : Yes
[30/01/2015 17:50:01] Finding accounts in : /var/www/OpenJabNab/server/bin/accounts
[30/01/2015 17:50:01] Total of accounts: 1
[30/01/2015 17:50:01] Finding plugins in : /var/www/OpenJabNab/server/bin/plugins
[30/01/2015 17:50:01] Loading libplugin_airquality.so : airquality OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_annuaire.so : annuaire OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_auth.so : auth OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_callurl.so : callurl OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_cinema.so : cinema OK, Enable : Yes
[30/01/2015 17:50:01] Cron Started...
[30/01/2015 17:50:01] Cron Register : Clock - ven. janv. 30 18:00:00 2015
[30/01/2015 17:50:01] Loading libplugin_clock.so : clock OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_colorbreathing.so : colorbreathing OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_dice.so : dice OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_ears.so : ears OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_ephemeride.so : ephemeride OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_gmail.so : gmail OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_locate.so : locate OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_memo.so : memo OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_msgall.so : msgall OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_music.so : music OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_packet.so : packet OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_ratp.so : ratp OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_record.so : record OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_rfid.so : rfid OK, Enable : Yes
[30/01/2015 17:50:01] Loading libplugin_sleep.so : sleep OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_stats.so : stats OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_surprise.so : surprise OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_taichi.so : taichi OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_test.so : test OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_tts.so : tts OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_tv.so : tv OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_weather.so : weather OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_webradio.so : webradio OK, Enable : Yes
[30/01/2015 17:50:02] Loading libplugin_wizzflux.so : wizzflux OK, Enable : Yes
[30/01/2015 17:50:02] Finding bunnies in : /var/www/OpenJabNab/server/bin/bunnies
[30/01/2015 17:50:02] Finding ztamps in : /var/www/OpenJabNab/server/bin/ztamps
[30/01/2015 17:50:02] XMPP Port is: 5222
[30/01/2015 17:50:02] Parsing of HTTP Api is enabled
[30/01/2015 17:50:28] Requesting LOCATE for tag 0019db000ee0
[30/01/2015 17:51:00] User login : jojo
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz


Age : 37
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 10510

MessageSujet: Re: Problème de connection a mon serveur   Dim 8 Fév 2015 - 23:29

Si mes souvenirs sont bons (je me plonge pas dans le code à 23h30), l'IP du lapin est inscrite quand il se connecte en XMPP (donc sur le port 5222)
Tu as donné quoi comme configuration au lapin (violet platform) ?
Tu as bien un serveur DNS, ou tu essaies d'y accéder par l'IP ?

_____________________________


Toutes les infos sur mon serveur openJabNab sont sur mon wiki nabaztag/tag et openJabnab
Revenir en haut Aller en bas
http://openjabnab.fr/
jojolapinou
Lapin nain
Lapin nain


Age : 33
Localisation : judo63
Nabaztag : lejojolapinou
Nbr de messages : 5
Carottes : 3646

MessageSujet: Re: Problème de connection a mon serveur   Lun 9 Fév 2015 - 19:11

Bonsoir,

Et merci pour la reponse (surtout à 23h30 nabzsmile )

Dans violet platform j'ai mis ojn.nabaztag.tag
J'ai bien un serveur dns bind9 que j'ai configuré comme expliqué dans le tutoriel (à la différence que j'ai utilisé ojn.nabaztag.tag au lieu de ojn.raspberry.pi). et quand je ping ojn.nabaztag.tag il repond.

mon fichier opennabjab.ini

Code:

[Config]
httpListener = true
httpApi = true
httpVioletApi = true
xmppListener = true
RealHttpRoot = /var/www/OpenJabNab/http-wrapper/ojn_local/
HttpRoot = ojn_local
HttpPluginsFolder = plugins
StandAloneAuthBypass = true
AllowAnonymousRegistration=true
AllowUserManageBunny=true
AllowUserManageZtamp=true
SessionTimeout=300
TTS=acapela
MaxNumberOfBunnies=64
MaxBurstNumberOfBunnies=72

[OpenJabNabServers]
PingServer=ojn.nabaztag.tag
BroadServer=ojn.nabaztag.tag
XmppServer=192.168.0.2
ListeningHttpPort=8080
ListeningXmppPort=5222

[Log]
LogFile=openjabnab.log
LogFileLevel=Debug
LogScreenLevel=Warning
DisplayCronLog=false
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz


Age : 37
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 10510

MessageSujet: Re: Problème de connection a mon serveur   Lun 9 Fév 2015 - 20:02

XmppServer, il faudrait aussi mettre ojn.nabaztag.tag
Je crois que ce que le lapin n'arrive pas à faire, c'est la connection Xmpp sur une IP... et là, tu lui donnes une IP (alors que les 2 "*Server" autres sont corrects)

_____________________________


Toutes les infos sur mon serveur openJabNab sont sur mon wiki nabaztag/tag et openJabnab
Revenir en haut Aller en bas
http://openjabnab.fr/
Pixel du Rezo
Special Nabz
Special Nabz


Age : 37
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 10510

MessageSujet: Re: Problème de connection a mon serveur   Lun 9 Fév 2015 - 20:05

C'est, semblerait-il, une limitation du firmware du lapin.
Mais pour l'instant, nous ne savons pas créer un nouveau firmware...

C'est vraiment dommage, car il y a au minimum 2 points qu'il faudrait corriger dans le firmware pour débloquer pas mal de situations.
Et on pourrait aussi mettre en place dans le firmware un mode pour qu'il reboote sans ses lumières.. car les reboots en pleine nuit, c'est pas terrible pour ceux qui ont le lapin dans une chambre yellownabzwink On pourrait limiter cela à une respiration de couleur spéciale par exemple, pour savoir l'étape de boot en cours.

Mais pour cela, il faut pouvoir compiler un firmware...

_____________________________


Toutes les infos sur mon serveur openJabNab sont sur mon wiki nabaztag/tag et openJabnab
Revenir en haut Aller en bas
http://openjabnab.fr/
jojolapinou
Lapin nain
Lapin nain


Age : 33
Localisation : judo63
Nabaztag : lejojolapinou
Nbr de messages : 5
Carottes : 3646

MessageSujet: Re: Problème de connection a mon serveur   Lun 9 Fév 2015 - 21:35

Re bonsoir,

Je viens de tester et effectivement le problème viens de la. Merci bien maintenant le lapin respire.

Oui je comprend bien que ca peut être dérangeant les lumières la nuit (il est dans ma chambre aussi). Mais bon pour cela il faudrait les sources du fimrware mais je ne pense pas qu'elles soient dispo non ?


En tous cas merci bien. nabzsmile
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: Problème de connection a mon serveur   

Revenir en haut Aller en bas
 
Problème de connection a mon serveur
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Problème de connexion aprés backup de sauvegarde
» [RESOLU] Problème connection Neuf Box (SFR) : HELP !!!!
» Serveur Ventrilo
» Problème de connection, lapin rouge !
» problème de connection au forum

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: Les Nabaztags sont sauvés ! Les solutions... :: [OJN] OpenJabNab-
Sauter vers: