Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
htristra
Silver Nabz
Silver Nabz


Age : 41
Localisation : Val d'oise France
Nabaztag : lapou et laptaf
Nbr de messages : 364
Carottes : 2465

MessageSujet: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mar 23 Aoû 2011 - 0:05

Bonjour aux dév,

je viens de récupérer les sources sur GitHub pour mettre à jour mon serveur.
qmake -r && make : Ok
cp -rv . vers la destination de prod : Ok pour server et http-wrapper

Démarrage server : OK (cf trace)

Code:

-- OpenJabNab Start --
Finding tts in : /home/apache/jabnab/server/bin/tts
Loading libtts_acapela.so : acapela OK, Enable : Yes
Loading libtts_google.so : google OK, Enable : Yes
Finding accounts in : /home/apache/jabnab/server/bin/accounts
Total of accounts: 15
Finding plugins in : /home/apache/jabnab/server/bin/plugins
Loading libplugin_annuaire.so : annuaire OK, Enable : Yes
Loading libplugin_auth.so : auth OK, Enable : Yes
Loading libplugin_boot.so : boot OK, Enable : Yes
Cron Started...
Cron Register : Clock - mar. août 23 00:00:00 2011
Loading libplugin_clock.so : clock OK, Enable : Yes
Loading libplugin_colorbreathing.so : colorbreathing OK, Enable : Yes
Loading libplugin_dice.so : dice OK, Enable : Yes
Loading libplugin_ears.so : ears OK, Enable : Yes
Loading libplugin_ephemeride.so : ephemeride OK, Enable : Yes
Loading libplugin_locate.so : locate OK, Enable : Yes
Loading libplugin_msgall.so : msgall OK, Enable : Yes
Loading libplugin_music.so : music OK, Enable : Yes
Loading libplugin_packet.so : packet OK, Enable : Yes
Loading libplugin_record.so : record OK, Enable : Yes
Loading libplugin_removesig.so : removesig OK, Enable : Yes
Loading libplugin_repeat.so : repeat OK, Enable : Yes
Loading libplugin_rfid.so : rfid OK, Enable : Yes
Loading libplugin_sleep.so : sleep OK, Enable : Yes
Loading libplugin_surprise.so : surprise OK, Enable : Yes
Loading libplugin_taichi.so : taichi OK, Enable : Yes
Loading libplugin_test.so : test OK, Enable : Yes
Loading libplugin_tts.so : tts OK, Enable : Yes
Loading libplugin_tv.so : tv OK, Enable : Yes
Loading libplugin_weather.so : weather OK, Enable : Yes
Loading libplugin_webradio.so : webradio OK, Enable : Yes
Loading libplugin_xmppport.so : xmppport OK, Enable : Yes
Finding bunnies in : /home/apache/jabnab/server/bin/bunnies
Finding ztamps in : /home/apache/jabnab/server/bin/ztamps
XMPP Port is: 5222
Parsing of HTTP Api is enabled
Parsing of HTTP Bunny messages is enabled
Current mode is standalone

mais au bout de quelques seconde, j'ai l'erreur suivante :
Code:

./openjabnab: symbol lookup error: ./openjabnab: undefined symbol: _ZN11HttpHandlerC1EP10QTcpSocketbbbb

le ldd sur le serveur donne :
Code:

root@xps1730:/home/apache/jabnab/server/bin# ldd openjabnab
   linux-gate.so.1 =>  (0xb76e6000)
   libcommon.so.1 => /home/apache/jabnab/server/bin/./libcommon.so.1 (0xb765e000)
   libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xb7520000)
   libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xb729b000)
   libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7282000)
   libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb718d000)
   libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7167000)
   libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7149000)
   libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb7002000)
   libz.so.1 => /usr/lib/libz.so.1 (0xb6fee000)
   libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb6fea000)
   libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb6fe5000)
   librt.so.1 => /lib/i686/cmov/librt.so.1 (0xb6fdc000)
   libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb6f13000)
   /lib/ld-linux.so.2 (0xb76e7000)
   libpcre.so.3 => /lib/libpcre.so.3 (0xb6edf000)

je fais du dev c/c++, quand j'ai ça, c'est qu'une de mes lib n'est pas à jour. Est ce la cas ?

A+


Dernière édition par htristra le Mer 24 Aoû 2011 - 2:32, édité 1 fois
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1185
Carottes : 3750

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mar 23 Aoû 2011 - 1:33

Vire le libplugin_boot.so, il n'existe plus sur le code actuel, et c'sans doute lui qui met le bordel ^^
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
htristra
Silver Nabz
Silver Nabz


Age : 41
Localisation : Val d'oise France
Nabaztag : lapou et laptaf
Nbr de messages : 364
Carottes : 2465

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mar 23 Aoû 2011 - 8:16

Salut,

j'avais déjà virer le plugin en lisant le forum mais cela n'a rien changé.
Mon conf :

Code:


[Config]
httpListener = true
httpApi = true
httpVioletApi = true
xmppListener = true
RealHttpRoot = /home/apache/jabnab/http-wrapper/ojn_local
HttpRoot = ojn_local
HttpPluginsFolder = plugins
StandAlone = true
StandAloneWelcome = true
StandAloneAuthBypass = false
StandAloneAuthBypassBunny =
Bootcode = /home/apache/jabnab/server/bin/bootc
StandAloneUseLocalBootcode =true
AllowAnonymousRegistration=true
AllowUserManageBunny=true
AllowUserManageZtamp=true
SessionTimeout=300
TTS=acapela
MaxNumberOfBunnies=64
MaxBurstNumberOfBunnies=72
httpViolet = true
SaveBootcode=true
ProxyUseLocalBootcode=false

[DefaultVioletServers]
BootServer=r.nabaztag.com
BroadServer=broad.violet.net
PingServer=tagtag.nabaztag.objects.violet.net
XmppDomain=xmpp.nabaztag.com
XmppServer=rhoen.violet.net

[OpenJabNabServers]
PingServer=jabnab.comeonpeace.com
BroadServer=jabnab.comeonpeace.com
XmppServer=jabnab.comeonpeace.com
ListeningHttpPort=8080

[Log]
LogFile=openjabnab.log
LogFileLevel=Debug
LogScreenLevel=Warning
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1185
Carottes : 3750

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mar 23 Aoû 2011 - 9:23

Quand j'vois "Loading libplugin_boot.so : boot OK, Enable : Yes" dans le log, j'avais moyen d'avoir des doutes ^^

Ton openjabnab.ini n'est pas à jour des dernières modifs non plus, faudrait voir à faire quelque chose...

Vérifie bien que t'as remplacé la libcommon ET l'executable d'OJN (ex, serveur OJN coupé, sinon cp ne remplace pas l'exe)... Normalement, ca n'a pas de raison d'faire ça...

> Sinon, compile en mode "debug" et lance le dans GDB
Pour passer en "debug", lance le script ./toDebug.sh UNE SEULE FOIS (sinon tu casses tout yellownabzsmile)
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
don
Lapin nain
Lapin nain


Localisation : France
Nbr de messages : 35
Carottes : 2081

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mar 23 Aoû 2011 - 21:01

J'ai eu exactement la même et comme j'avais pas le temps de fouiller plus j'ai fait un revert sur la branche github vers un commit plus stable en attendant d'avoir plus de temps (quelque chose comme git checkout -b )
Revenir en haut Aller en bas
htristra
Silver Nabz
Silver Nabz


Age : 41
Localisation : Val d'oise France
Nabaztag : lapou et laptaf
Nbr de messages : 364
Carottes : 2465

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mar 23 Aoû 2011 - 21:34

De toute façon, ma debian déconne à moitié, je suis en train de refaire l'installation de la distribution.
Je vous tiens au courant.
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz


Localisation : France
Nbr de messages : 1185
Carottes : 3750

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mer 24 Aoû 2011 - 1:23

don a écrit:
J'ai eu exactement la même et comme j'avais pas le temps de fouiller plus j'ai fait un revert sur la branche github vers un commit plus stable en attendant d'avoir plus de temps (quelque chose comme git checkout -b )
C'est... pas normal comme comportement... Faut essayer de compiler ma version Git, au cas ou... Mais si tous les fichiers de run (les lib, l'exe d'OJN, ...) sont mis a jour, ca devrait pas poser probleme.

Tu peux aussi tenter un make clean; make au cas ou...

htristra a écrit:
De toute façon, ma debian déconne à moitié, je suis en train de refaire l'installation de la distribution.
Je vous tiens au courant.
Arf, pas cool ca.... Bon courage yellownabzsmile
Revenir en haut Aller en bas
http://wiki.openjabnab.fr/
htristra
Silver Nabz
Silver Nabz


Age : 41
Localisation : Val d'oise France
Nabaztag : lapou et laptaf
Nbr de messages : 364
Carottes : 2465

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mer 24 Aoû 2011 - 2:30

salut,

ayé tout remarche. nabzcheers
La distrib est toute neuve, OJN aussi, et le tout marche.
J'en ai profité pour mettre les surprises de alfinium (http://nabaztag.forumactif.fr/t13451-serveur-ojn-alfinium-une-petite-pierre-en-plus). La première diffusion sera à 2h49 donc je l'entendrais pas (ben vi je bosse demain...).

Par contre, j'avais lu un post sur l'annuaire, il me semble. Je ne le trouve plus. Quelqu'un à le lien sous le coude ?

Merci à vous pour vos réponses et votre aide.

Revenir en haut Aller en bas
baba-djangane
Lapin nain
Lapin nain


Localisation : 28000
Nabaztag : babadjangane
Nbr de messages : 31
Carottes : 2089

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mer 24 Aoû 2011 - 18:11

Bonjour,

Tu vas dans serveur --> Register the bunny on the central directory --> configurer



Voila ca devrait fonctionner
Revenir en haut Aller en bas
http://babadjangane.no-ip.org/ojn_admin/index.php
htristra
Silver Nabz
Silver Nabz


Age : 41
Localisation : Val d'oise France
Nabaztag : lapou et laptaf
Nbr de messages : 364
Carottes : 2465

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mer 24 Aoû 2011 - 18:39

parfait, c'est en place.
Je me vois sur l'annuaire.

Merci bien.
Revenir en haut Aller en bas
baba-djangane
Lapin nain
Lapin nain


Localisation : 28000
Nabaztag : babadjangane
Nbr de messages : 31
Carottes : 2089

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mer 24 Aoû 2011 - 18:57

Bonjour,

Par contre pour ma part je suis inscris sur l'annuaire mais je ne me vois pas enfin je ne vois pas le lapin babadjangane.

Bon c'est peut-être du au fait que lors de mes essais j'avais inscris le lapin sous le non de lapin6.

Je ne sais pas à qui m'adresser pour avoir l'info....

C'est pas d'une urgence primordiale...... yellownabzhappy
Revenir en haut Aller en bas
http://babadjangane.no-ip.org/ojn_admin/index.php
baba-djangane
Lapin nain
Lapin nain


Localisation : 28000
Nabaztag : babadjangane
Nbr de messages : 31
Carottes : 2089

MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   Mer 24 Aoû 2011 - 18:58

Oupssssssssssssssssssssss me voila ca fonctionne....

Sujet clos
Revenir en haut Aller en bas
http://babadjangane.no-ip.org/ojn_admin/index.php
Contenu sponsorisé




MessageSujet: Re: [RESOLU] [UPDATE SERVEUR htristra] undefined symbol:   

Revenir en haut Aller en bas
 
[RESOLU] [UPDATE SERVEUR htristra] undefined symbol:
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [RESOLU]problème serveur ? Lapin lent !
» [RESOLU] Nouveau serveur OJN petits problèmes
» Informations serveur htristra : jabnab.comeonpeace.com
» [OJN] [RESOLU] problème d'installation serveur
» [SYS] BusyBox update - Web & Ftp servers

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: Les Nabaztags sont sauvés ! Les solutions... :: [OJN] OpenJabNab-
Sauter vers: