Forum des Objets Communicants et Solutions pour les Libérer...
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.

Forum des Objets Communicants et Solutions pour les Libérer...


 
AccueilAccueil  GalerieGalerie  RechercherRechercher  Dernières imagesDernières images  S'enregistrerS'enregistrer  Connexion  
Le Deal du moment : -25%
PC portable GIGABYTE AERO 16 15.6” Ultra HD ...
Voir le deal
1499 €

 

 OpenJabNab v0.01a

Aller en bas 
+32
don
calbo
titibou
cbrassel
Bpellissier
wizz.cc
Humanbomb
ploc
_melka
BlueCore18
maddam
loic_d
giantpopples
Cyrille37
bbk
Bidule
cep33
cttn
RedoX
k
Harfangdesneiges
Wass
picsoung
nag
Phabbrrysse
plokiju
oaz
jbx028
Hunta_de_la_Radieuse
Oliv4945
Pixel du Rezo
Toms2809
36 participants
Aller à la page : Précédent  1, 2, 3, 4 ... 8 ... 14  Suivant
AuteurMessage
Pixel du Rezo
Special Nabz
Special Nabz



Nbr de messages : 2708

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 18 Déc 2009 - 0:16

Oui, n'hesitez pas à donner des logs, messages d'erreur, etc..
J'essayerais de vous sortir de ce mauvais pas.. même si je ne garanti rien nabzsmile

N'oubliez pas de poster aussi le openjabnab.ini (éventuellement en brouillant les parties relatives à vos noms d'hôtes perso si vous le souhaitez).
Il peut enfin être important d'avoir la révision SVN utilisée pour compiler...
Revenir en haut Aller en bas
http://openjabnab.fr/
plokiju
Lapin nain
Lapin nain



Age : 49
Localisation : France, 72
Nabaztag : nabily
Nbr de messages : 14
Carottes : 5180

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeSam 19 Déc 2009 - 14:24

Je viens de trouver mon bug ! j'avais une erreur dans le fichier .ini

J'ai quand même un soucis avec le mod rewrite de apache ;-(

j'arrive pas a le faire fonctionner . pour le moment j'ai bidouillé pour le fichier bc.jsp, mais je ne vais pas reproduire la bidouille pour tous les autres ;-(

Concernant le mode rewrite, sous easyphp j'ai fait ceci :

décommenter la ligne LoadModule rewrite_module modules/mod_rewrite.so

et c'est tout ... y'a autre chose a faire ?

J'ai trouvé :
il faut vérifier qu'on a bien AllowOverride All dans son fichier de conf apache sinon il ne prend pas en compte les .htaccess

Ensuite j'ai la log :
requesting LOCATE for tag 001122334455

et plus rien : le lapinou reste "planté" avec une lumiere orange sur le ventre nabzasking

c'est reparti pour le debug.

plokiju
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Déc 2009 - 9:52

plokiju a écrit:

Ensuite j'ai la log :
requesting LOCATE for tag 001122334455

et plus rien : le lapinou reste "planté" avec une lumiere orange sur le ventre nabzasking

c'est reparti pour le debug.

plokiju
Tu peux donner ton .ini (par MP si tu veux pas tout donner) ?
Tu es en mode standalone ou pas ?

Tu pourrais donner la fin du dump.log et du openjabnab.log ?
Revenir en haut Aller en bas
http://openjabnab.fr/
plokiju
Lapin nain
Lapin nain



Age : 49
Localisation : France, 72
Nabaztag : nabily
Nbr de messages : 14
Carottes : 5180

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeMar 5 Jan 2010 - 20:24

De retour de vacances . 10 jours sans internet, téléphone, télé et lapin. ça change !

mon .ini est le suivant :
Code:

[OpenJabNabServers]
ListeningHttpPort=8080
XmppPort=5222
XmppServer=10.0.0.5
PingServer=10.0.0.5
BroadServer=10.0.0.5

[Config]
httpListener = true
httpApi = true
httpViolet = true
xmppListener = true
RealHttpRoot = D:/Dev/nabaztag/trunk/http-wrapper/ojn_local/
HttpRoot = ojn_local
HttpPluginsFolder = plugins
StandAlone = false
StandAloneWelcome = false
StandAloneAuthBypass=false
StandAloneAuthBypassBunny=
Bootcode =

[DefaultVioletServers]
BootServer=r.nabaztag.com
BroadServer=broad.violet.net
PingServer=tagtag.nabaztag.objects.violet.net
XmppDomain=xmpp.nabaztag.com
XmppServer=rhoen.violet.net

[Log]
LogFile=logfile.log
LogFileLevel=Debug
LogScreenLevel=Debug


Tu remarqueras que je suis donc pas en standalone . d'ailleurs quel est la démarche pour passer en standalone ? que mettre dans bootcode par exemple ?

et pour finir les logs que je viens de produire :

Code:

[05/01/2010 20:17:23] -- OpenJabNab Start --
[05/01/2010 20:17:23] Finding plugins in : D:/Dev/nabaztag/trunk/openjabnab/bin/plugins
[05/01/2010 20:17:23] Loading plugin_boot.dll : boot OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_dice.dll : dice OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_locate.dll : locate OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_packet.dll : packet OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_removesig.dll : removesig OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_rfid.dll : rfid OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_sleep.dll : sleep OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_test.dll : test OK, Enable : Yes
[05/01/2010 20:17:23] Loading plugin_tts.dll : tts OK, Enable : Yes
[05/01/2010 20:17:24] Loading plugin_tv.dll : tv OK, Enable : Yes
[05/01/2010 20:17:24] Parsing of HTTP Api is enabled
[05/01/2010 20:17:24] Parsing of HTTP Bunny messages is enabled
[05/01/2010 20:17:24] Current mode is connected to Violet
[05/01/2010 20:18:29] Requesting BOOT for tag letagdemonlapin with version 0.0.0.10
[05/01/2010 20:18:30] Reply : {blablabla}
[05/01/2010 20:18:35] pluginLocate uri {/vl/locate.jsp}
[05/01/2010 20:18:35] Requesting LOCATE for tag letagdemonlapin
[05/01/2010 20:18:35] pluginLocate violetAnswer {ping tagtag.nabaztag.objects.violet.net
broad broad.violet.net
xmpp_domain xmpp.nabaztag.com

}
[05/01/2010 20:18:35] pluginLocate locateString {ping 10.0.0.5
broad 10.0.0.5
xmpp_domain 10.0.0.5
}
[05/01/2010 20:19:21] -- OpenJabNab Close --
[05/01/2010 20:19:21] Cron Started...

j'ai ajouter quelques traces pour essayer de comprendre violetAnswer et locateString .

Merci pour ton aide Pixel !
Revenir en haut Aller en bas
nag
Special Nabz
Special Nabz
nag


Age : 49
Localisation : agen
Nabaztag : nag (V2) frankennag (V2) KarotzNag (kz) nag et frankennag sont sous serveur OpenNag[ONG]
Nbr de messages : 3601
Carottes : 12826

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeMar 5 Jan 2010 - 22:07

nabzciao

@plokiju : pour passer en mode StandAlone tu édites ton .ini

StandAlone = false

devient :

StandAlone = true

mais je ne suis pas sûr que ca suffise.........tu peux confirmer Pixel ? nabzlol

_____________________________


Reconnecter son Nabaztag/tag en 5mn sur OpenNag (serveur libre et indépendant) cliquer sur la bannière ci-dessous

OpenJabNab v0.01a - Page 3 Dac52753da91392d9d06

En savoir plus sur OpenNag (fonctionnement des options et esprit) : Serveur OpenNag
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Mon blog (ou comment mettre son Nabaztag sur batteries) --> http://leblogdenag.eklablog.com
et aussi : https://nabaztag.forumactif.fr/nabaztag-life-f4/bricolage-autonomie-pour-les-lapins-t7460-210.htm
Revenir en haut Aller en bas
plokiju
Lapin nain
Lapin nain



Age : 49
Localisation : France, 72
Nabaztag : nabily
Nbr de messages : 14
Carottes : 5180

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeMer 6 Jan 2010 - 10:08

nabzdrunk

@nag : je pense avoir fait ce test et que ce n'est pas suffisant.

mais promis des que j'ai réussis à tout comprendre je ferais un ajout aux docs de Pixel.

Edit : J'ai refait le test et effectivement ça ne suffit pas il manque surtout le fichier "bootcode"

est ce que quelqu'un sait ?

Edit 2 : je pense que j'ai trouver une solution dans le post suivant :

opnnab en local

mais est ce que ça fonctionne toujours ?

plokiju
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeJeu 7 Jan 2010 - 11:05

Pour le bootcode, il suffit de le télécharger sur le serveur officiel.
(il faut reprendre l'adresse /vl/bc.jsp ... )

L'inconvénient du mode standalone pour le moment est que tu ne peux pas revenir au mode connecté sans une intervention des équipes de Violet (Mindscape).. et je ne connais pas la réactivité des équipes en ce moment...

Pour ta config, je pense que je vois d'où vient le problème.

En effet, tu as la config suivante :
Code:
[OpenJabNabServers]
ListeningHttpPort=8080
XmppPort=5222
XmppServer=10.0.0.5
PingServer=10.0.0.5
BroadServer=10.0.0.5

Ce qui correspond à des adresses locales...
Il faut que ca soit une adresse internet, et que avec un routeur tu rediriges vers la bonne machine (pour le port 80 et 5222).
Revenir en haut Aller en bas
http://openjabnab.fr/
plokiju
Lapin nain
Lapin nain



Age : 49
Localisation : France, 72
Nabaztag : nabily
Nbr de messages : 14
Carottes : 5180

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeJeu 7 Jan 2010 - 13:12

Merci pour les information Pixel du Rezo.

je vais télécharger ce bootcode pour tester le mode Standalone :

si je comprend bien il suffit que je dump dans un fichier la réponse que me fait violet pour la première requête du lapinou ?

pour l'inconvénient, ça ne me semble pas forcément problématique pour moi . je cherche bien à avoir un lapin "local" . J'ai d'ailleurs deux lapins, donc l'un d'entre eu restera connecter au monde.

Pour les adresses locales. tu veux dire qu'il attend forcément une adresse du genre

lapinou.chezmoi.fr

ou plutot des adresses "multiple" :

nabaztag.chezmoi.fr
broad.chezmoi.fr
xmpp.chezmmoi.fr

(même si au final elle pointe au même endroit).

je pourrais peut etre simplement définir des adresse "bidon" dans le fichier hosts de mon PC ?

genre :

Code:
10.0.0.5 lapinou.chezmoi.fr

et mettre ensuite dans le fichier de conf :


Code:
[OpenJabNabServers]
ListeningHttpPort=8080
XmppPort=5222
XmppServer=lapinou.chezmoi.fr
PingServer=lapinou.chezmoi.fr
BroadServer=lapinou.chezmoi.fr

bon ... je vais faire des tests ce soir .

Plokiju
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeJeu 7 Jan 2010 - 18:31

En fait, j'ai dis ca, mais je ne suis pas certain que ca soit la cause du problème
Ca dépend de ta configuration... Ton serveur et le lapin sont sur le même réseau ou pas ?

Car en théorie, on peut indiquer des IP ou des adresses... ton problème ressemble plus à une absence de communication entre les 2 lapins après l'initialisation.

Par exemple... tu as mis quoi dans la config du lapin (la page avancée où tu remplace r.nabaztag.com/vl par ton serveur ) ???
Revenir en haut Aller en bas
http://openjabnab.fr/
Wass
Nabz Junior
Nabz Junior
Wass


Age : 33
Localisation : France
Nabaztag : Jarjarbing
Nbr de messages : 99
Carottes : 4943

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeJeu 7 Jan 2010 - 22:27

salut en fait fait j'ai pas bine compris l'utilité d'openjabnab mais vu que je ne suis jamais contre une petite bidouille ca m'interesse lol ci quelqu'un peut m'expliquer merci d'avance
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 8 Jan 2010 - 10:21

Alors, pour résumer, openJabNab est le openNab en version Jabber.

C'est à dire qu'il se place entre le lapin et les serveurs officiels, afin de pouvoir intercepter des messages, les modifier, les supprimer, ou eventuellement en rajouter.
Cela permet de rajouter des fonctions au lapin, cela en utilsiant le nouveau protocole utilisé par les lapin:pin à savoir Jabber.
Opennab faisait la meme chose mais avec l'ancien protocole (http uniquement).

ps: j'adore les fringues de ton lapin yellownabzwink
Revenir en haut Aller en bas
http://openjabnab.fr/
Wass
Nabz Junior
Nabz Junior
Wass


Age : 33
Localisation : France
Nabaztag : Jarjarbing
Nbr de messages : 99
Carottes : 4943

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 8 Jan 2010 - 12:37

ok quel sont les risques de cette instalation?? ET SURTOUT comment on fait lol?c'est dur???
tu aurai un exemple concret d'un truc que l'on peut faire avec openjabnab et que l'on ne peut pas faire normalement??
mon idée etant d'atribuer un controle vocal pour lancer par exemple un callurl(ex: lance lance massilia sound system mon lapin et hop avec nabexec il lance massila sur itunes de mon ordi)ca serai trop fort!!!!!
merci de ta réponse

c'est moi qui l'ai fait tout seul nabzdevil lol
Revenir en haut Aller en bas
Harfangdesneiges
Special Nabz
Special Nabz
Harfangdesneiges


Age : 26
Localisation : Quelque part sur la côte d'Azur
Nbr de messages : 1383
Carottes : 5868

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeMar 4 Mai 2010 - 19:36

Apparemment les sources ne sont plus dans le SVN, quelqu'un pourrait me les donner s'il vous plaît ? (Et le projet a l'air un peu mort aussi yellownabzsad )
Revenir en haut Aller en bas
Wass
Nabz Junior
Nabz Junior
Wass


Age : 33
Localisation : France
Nabaztag : Jarjarbing
Nbr de messages : 99
Carottes : 4943

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeMar 4 Mai 2010 - 20:43

Oué j'ai un peut l'impressions aussi
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeMar 18 Mai 2010 - 13:42

Le projet n'est pas mort...
Il est plutôt au ralenti.

Je l'utilise quotidiennement, et il fonctionne plutôt pas mal.
Dernièrement, le flux RSS utilisé pour le programme TV a été modifié, ce qui empeche le plugin TV de fonctionner correctement. Je suis en train de tester une nouvelle version avant de commiter tout ca sur le SVN.

Sinon, les sources sont toujours dispos sur sourceforge, mais il n'y a pas d'archive (il n'y en a jamais eu). Il faut faire un checkout du svn :

svn co https://openjabnab.svn.sourceforge.net/svnroot/openjabnab openjabnab

Sinon, vous êtes tous les bienvenue pour ajouter de nouvelles fonctionnalités, et/ou pour demander d'éventuels ajouts (qui seront intégrés sous réserve de faisabilité et de temps).

De mon côté, j'envisage de faire une application pour les téléphone Android afin de s'interfacer sur openJabNab.
Revenir en haut Aller en bas
http://openjabnab.fr/
k
Lapin nain
Lapin nain



Localisation : Bordeaux, France
Nabaztag : Squeeze (v2)
Nbr de messages : 7
Carottes : 4632

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 18:11

Hi !!

J'ai récupérer openjnab via le svn mais je n'arrive pas à installer la partie "serveur xmpp".
Lorsque je lance qmake -r, j'obtiens ce message d'erreur:
Code:

QMAKESPEC has not been set, so configuration cannot be deduced

pour info je suis sous debian "stable"

Quelqu'un aurait il une idée ?

Merci.
Revenir en haut Aller en bas
RedoX
Platinum Nabz
Platinum Nabz
RedoX


Localisation : France
Nbr de messages : 1287
Carottes : 6031

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 18:18

Bonjour,

Dans quel répertoire, essayes-tu de lancer cette commande ?

A tout hasard, fais une recherche sur google de ton message d'erreur, tu trouveras ta solution je pense yellownabzwink Ca semble venir d'un problème d'environnement.

La version du SVN compile très bien ^^

Cdlt,
RedoX
Revenir en haut Aller en bas
https://openjabnab.fr/
k
Lapin nain
Lapin nain



Localisation : Bordeaux, France
Nabaztag : Squeeze (v2)
Nbr de messages : 7
Carottes : 4632

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 19:00

Euh ... j'ai trouvé ... il me manquait une lib :|
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 19:47

S'il y a d'autres soucis pour l'installation, ou l'utilisation, n'hesite pas à demander !
La version SVN est un peu bancale en standalone, mais j'ai une version qui fonctionne mieux sous la main si besoin.

Ne pas hésiter à me faire un MP en attendant que je commite tout ca !
Revenir en haut Aller en bas
http://openjabnab.fr/
k
Lapin nain
Lapin nain



Localisation : Bordeaux, France
Nabaztag : Squeeze (v2)
Nbr de messages : 7
Carottes : 4632

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 19:51

Bon ça tourne:
Code:


-- OpenJabNab Start --
Finding plugins in : /home/k/openjabnab/bin/plugins
Loading libplugin_boot.so : boot OK, Enable : Yes
Loading libplugin_dice.so : dice OK, Enable : Yes
Loading libplugin_locate.so : locate OK, Enable : Yes
Loading libplugin_packet.so : packet OK, Enable : Yes
Loading libplugin_removesig.so : removesig OK, Enable : Yes
Loading libplugin_rfid.so : rfid OK, Enable : Yes
Loading libplugin_sleep.so : sleep OK, Enable : Yes
Loading libplugin_test.so : test OK, Enable : Yes
Loading libplugin_tts.so : tts OK, Enable : Yes
Downloading MP3 file : http://vaas3.acapela-group.com/MESSAGES/008101109111095119101098/sounds/130518990_c2ede01ac61a8.mp3
Cannot open sound file for writing
Loading libplugin_tv.so : tv OK, Enable : Yes
Parsing of HTTP Api is enabled
Parsing of HTTP Bunny messages is enabled
Current mode is connected to Violet

Voici mon fichier de configuration:
Code:


[Config]
httpListener = true
httpApi = true
httpViolet = true
xmppListener = true
RealHttpRoot = /.../actif/nabaztag/ojn_local/
HttpRoot = ojn_local
HttpPluginsFolder = plugins
StandAlone = false
StandAloneWelcome = false
StandAloneAuthBypass=false
StandAloneAuthBypassBunny=
Bootcode =

[DefaultVioletServers]
BootServer=r.nabaztag.com
BroadServer=broad.violet.net
PingServer=tagtag.nabaztag.objects.violet.net
XmppDomain=xmpp.nabaztag.com
XmppServer=rhoen.violet.net

[OpenJabNabServers]
PingServer=badplayer.fr
BroadServer=badplayer.fr
ListeningHttpPort=8080
XmppServer=badplayer.fr
XmppPort=5222

[Log]
LogFile=openjabnab.log
LogFileLevel=Debug
LogScreenLevel=Warning

J'ai modifié la config du lapin en remplacant r.nabaztag.com/vl par badplayer.fr/vl mais mon lapin a toujours le nez qui clignote vert/orange ...

J'ai loupé quoi ?
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 20:56

Essayes de mettre l'adresse IP de ton serveur (88.163.64.167 ? ) dans XmppServer.
Car si tu mets un nom de domaine, il faut faire une configuration particulière dans la gestion de ton DNS, et tu n'as peut-être pas accès à tout ça.

Sinon,
RealHttpRoot = /.../actif/nabaztag/ojn_local/
Il me semble que tu as un point en trop ...
Et les logs montrent un problème de droit d'écriture (mais si tu es arrivé là, tu devrais géré ce point sans trop de soucis ! )
Revenir en haut Aller en bas
http://openjabnab.fr/
RedoX
Platinum Nabz
Platinum Nabz
RedoX


Localisation : France
Nbr de messages : 1287
Carottes : 6031

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 21:00

Bonsoir,

J'appuie ce que vient de dire Pixel, (même si pour la partie DNS j'ai pas eu besoin de faire ça sur mon install, faut juste penser à ouvrir le port 5222 sur le serveur). Essaye avec l'IP

Verifie ta config (mets le path complet au lieu d'utiliser des .. )

Vérifie ton installation... Si on va à l'URL badplayer.fr/vl on ne devrait pas tomber sur un 404
sur badplayer.fr/ojn_admin/ non plus on ne devrait pas avoir un 404...

Vérifie que t'as bien installé la partie Web d'OJN yellownabzwink

Edit: Au passage, si tu veux utiliser OJN pour faire tourner ton lapin en local, je tiens à préciser que cette partie n'est pas opérationnelle pour le moment. Le seul "mode" disponible est le mode connecté. N'utilise pas le plugin Sleep non plus, celui du SVN provoque une segfault.
En fait, pour le moment OJN sert plus à analyser le dialogue du lapin que comme serveur à proprement parler.

Cdlt,

RedoX
Revenir en haut Aller en bas
https://openjabnab.fr/
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeVen 25 Juin 2010 - 23:15

Effectivement, tu as un problème de configuration au niveau apache.
Il faut que ton répertoire http-wrapper soit accessible sur le port 80, à l'adresse badplayer.fr

Si tu peux avoir des sous-domaines, je te conseille de faire un sous-domaine ojn.badplayer.fr qui pointe vers ton répertoire http-wrapper, comme ca, tu gardes ton badplayer.fr actuel ...
Revenir en haut Aller en bas
http://openjabnab.fr/
k
Lapin nain
Lapin nain



Localisation : Bordeaux, France
Nabaztag : Squeeze (v2)
Nbr de messages : 7
Carottes : 4632

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeSam 26 Juin 2010 - 17:42

Et si je le met dans un répertoire (ex: nabaztag) à la racine de mon apache ? Il est accessible via http://badplayer.fr/nabaztag/ donc pas besoin d'un sous domaine si ?

Ceci dit je ne vois aucun dossier ou fichier nommé vl donc j'ai forcement une erreur 404 quand je vais sur badplayer.fr/vl ...

Ensuite le serveur qui héberge est sur mon LAN, donc je suis pas persuadé que mettre mon ip wan soit la bonne solution.

Je vais faire qques tests de mon coté et si il y a moyen est ce qu'il serait possible de voir ça sur msn avec l'un de vous (Pixel du Rezo ou RedoX) ?

Merci.
Revenir en haut Aller en bas
Pixel du Rezo
Special Nabz
Special Nabz



Age : 43
Localisation : Montpellier
Nabaztag : Ptiloo (V1), Kymoo (V2), Mymoo (V2), Lyloo (V2), Maryloo (V2), Faitoo (V2), Titoo (V2), Kachoo (Karotz)
Nbr de messages : 2708
Carottes : 12684

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeSam 26 Juin 2010 - 17:54

k a écrit:
Et si je le met dans un répertoire (ex: nabaztag) à la racine de mon apache ? Il est accessible via http://badplayer.fr/nabaztag/ donc pas besoin d'un sous domaine si ?

Ceci dit je ne vois aucun dossier ou fichier nommé vl donc j'ai forcement une erreur 404 quand je vais sur badplayer.fr/vl ...

Ensuite le serveur qui héberge est sur mon LAN, donc je suis pas persuadé que mettre mon ip wan soit la bonne solution.

Je vais faire qques tests de mon coté et si il y a moyen est ce qu'il serait possible de voir ça sur msn avec l'un de vous (Pixel du Rezo ou RedoX) ?

Merci.

Pour le répertoire vl qui n'existe pas, c'est normal.
si tu regardes bien, tu as un fichier .htaccess, qui active le mode rewrite d'apache, et qui renvoye presque tout sur le fichier openjabnab.php
Code:
RewriteEngine on
[...]
RewriteRule    ^.*$    /openjabnab.php [L]

C'est ce fichier openjabnab.php qui s'occupe de tout.

Si tu es sur ton LAN, tu peux effectivement donner l'IP LAN de ton serveur dans la configuration.

Concernant la création d'un répertoire à la racine de ton apache, ça devrait pouvoir marcher, mais je ne garantie rien à ce sujet.

Je t'ai envoyé un MP avec mes coordonnées mail et gtalk si tu as besoin.
Revenir en haut Aller en bas
http://openjabnab.fr/
cttn
Lapin nain
Lapin nain



Localisation : L'internet
Nbr de messages : 24
Carottes : 4652

OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitimeSam 26 Juin 2010 - 23:49

Merci pour le lien a ce post, Pixel. nabzsmile

Je crois que j'ai le meme probleme que plokiju.

plokiju a écrit:
Je viens de trouver mon bug ! j'avais une erreur dans le fichier .ini

J'ai quand même un soucis avec le mod rewrite de apache ;-(

j'arrive pas a le faire fonctionner . pour le moment j'ai bidouillé pour le fichier bc.jsp, mais je ne vais pas reproduire la bidouille pour tous les autres ;-(

Concernant le mode rewrite, sous easyphp j'ai fait ceci :

décommenter la ligne LoadModule rewrite_module modules/mod_rewrite.so

et c'est tout ... y'a autre chose a faire ?

J'ai trouvé :
il faut vérifier qu'on a bien AllowOverride All dans son fichier de conf apache sinon il ne prend pas en compte les .htaccess

Ensuite j'ai la log :
requesting LOCATE for tag 001122334455

et plus rien : le lapinou reste "planté" avec une lumiere orange sur le ventre nabzasking

c'est reparti pour le debug.

plokiju

Est-ce quelque sait si ce probleme a ete resolu? Ou peut-etre des idees sur ce que j'ai fait de mal? Je ne peux pas faire plus de tests tant que mon lapin ne fait de connection au port 5222...
Revenir en haut Aller en bas
Contenu sponsorisé





OpenJabNab v0.01a - Page 3 Empty
MessageSujet: Re: OpenJabNab v0.01a   OpenJabNab v0.01a - Page 3 Icon_minitime

Revenir en haut Aller en bas
 
OpenJabNab v0.01a
Revenir en haut 
Page 3 sur 14Aller à la page : Précédent  1, 2, 3, 4 ... 8 ... 14  Suivant
 Sujets similaires
-
» API et OpenJabNab
» OpenJabNab
» Renseignement sur OPENJABNAB
» Connection openjabnab
» OpenJabNab Annuaire

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Forum des Objets Communicants et Solutions pour les Libérer... :: II. Nabaztag, Karotz, mir:ror, Dal:Dal (Violet Object Operating System) :: L'univers de Nabaztag :: Archives :: API-
Sauter vers: